JDK 6 으로 빌드해야 하는 프로젝트가 있어서 메이븐 3.3 을 실행했더니 아래와 같이 JDK 버전이 안 맞을 때의  예외 발생

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ma
ven/cli/MavenCli : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)


Maven Releases History 를 보니 JDK 6 을 지원하는 마지막 메이븐은 3.2.5 이므로 이 버전을 다운로드


Ref




blog comments powered by Disqus