원인

리눅스에 로그인하면 아래와 같이 cannot change locale 에러가 나는 경우가 있습니다. 


-bash: warning: setlocale: LC_ALL: cannot change locale (ko_KR.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (ko_KR.UTF-8)


이는 에러 메시지 뒤에 있는 로캘(Ex: ko_KR.UTF-8) 을 설정할 수 없다는 의미로 해당 로캘용 언어팩이 설치되지 않아서 발생합니다.

조치

로캘용 language pack 을 찾아서 설치해 주면 되며 아래는 korea  에 대한 로캘 패키지를 검색합니다.

$ yum search locale ko

========================================= Summary & Name Matched: ko, lang ==========================================
langpacks-ko.noarch : Korean langpacks meta-package
langpacks-ko.noarch : Korean langpacks meta-package
libreoffice-langpack-ko.x86_64 : Korean language pack for LibreOffice
glibc-langpack-ko.x86_64 : Locale data for ko
glibc-langpack-kok.x86_64 : Locale data for kok
============================================= Summary Matched: ko, lang ==============================================


검색이 완료되면 해당 언어 팩을 설치해 주면 됩니다.

$ sudo yum install glibc-langpack-ko


Ubuntu 의 경우 아래 패키지를 설치하면 됩니다.

$ sudo apt install language-pack-ko



같이 보기






blog comments powered by Disqus