Child pages
  • PHP composer install 시 devel 관련 library 설치 안하기

운영 환경이라면 PHPUnit이나 Faker 같은 개발 관련 도구를 설치할 필요가 없습니다.


특히 Laravel dusk 는 production 에 설치시 다음과 같은 에러를 발생시키기도 합니다.

In DuskServiceProvider.php line 43:
                                           
  It is unsafe to run Dusk in production.  


불필요한 개발 패키지를 설치 안하고 운영 환경에서 의존성을 설치하려면 컴포저에 다음 옵션을 주고 실행하면 됩니다.

composer install --no-dev



Ref